Print Thread
Performance
#63560 03/07/22 04:43 PM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
I use the 15.b6 / 32Bit
As soon as I select a text and copy it to the clipboard, the Developer hangs for 1-2 seconds. During this time no input is possible. I have turned off the copy history.
The 14.version does not do that.

Re: Performance
Heiko12345 #63564 03/08/22 10:14 AM
Joined: Aug 1999
Posts: 21,723
Member
Offline
Member
Joined: Aug 1999
Posts: 21,723
Did you disable the Clipboard History in the preferences (Preferences > User Interface > Editor > Clipboard)?


Marco Kalter
Allround Automations
Re: Performance
Heiko12345 #63566 03/08/22 11:25 AM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
Yes. Without activation it is better, but still hangs for about 1 second.

Re: Performance
Heiko12345 #63628 03/15/22 04:13 PM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
The hanger only occurs within Package Body. Package Header, Test- and SQL-Window without problems.

Re: Performance
Heiko12345 #63636 03/16/22 01:52 PM
Joined: Mar 2004
Posts: 161
V
Member
Offline
Member
V
Joined: Mar 2004
Posts: 161
"The hanger only occurs within Package Body. "
Not only with a package boby.
Currently I'm editing a small (200 lines) command window, and copying a small portion of text takes about a second.
I selected about 10 characters (a field name), pressed Ctrl+C, and for about a second, nothing happens. Even the right arrow does nothing.
Does not matter, if it is an SQL, Program, or Command Window. The same code hangs for a second, when I press Ctrl+C
Beta 7 installed, Clipboard history is turned off.

Re: Performance
Heiko12345 #63640 03/17/22 06:20 AM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
yes, that's right. The effect is greater with increasing code size and in each editor window.

Re: Performance
Heiko12345 #63712 03/28/22 12:14 PM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
(may be coincidence) is felt a little better with beta 8 but still not good

Re: Performance
Heiko12345 #63764 04/07/22 06:50 AM
Joined: May 2010
Posts: 17
H
Member
OP Offline
Member
H
Joined: May 2010
Posts: 17
This hang effect is almost non-existent after pc reboot. With runtime of the PC over the day (and start other tools gradually) this hang effect becomes larger. With other tools this hang does not occur.
This effect also occurs with colleagues and leads to non-acceptance (Version Beta 9).


Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.4