Print Thread
Auto-uppercase keywords, nothing else
#44802 10/19/12 01:44 PM
Joined: Oct 2012
Posts: 2
P
Member
OP Offline
Member
P
Joined: Oct 2012
Posts: 2
My coding buddy had keywords auto-capitalize as I typed them, with nothing else being capitalized. I couldn't find a way to do this on the forums, until I stumbled across this helpful article that offers a few suggestions. Here's one for upper-case, and thus easy to read, keywords:

  • Go to Tools > Preferences > User Interface > Code Assistant
  • Set Coding Style to Lowercase
  • Uncheck "Use original case if possible"
  • In Preferences, go to User Interface > Editor tab > Syntax Highlighting group
  • Keyword case to "Uppercase"


(Unfortunately the Beautifier and Code Assistant tools are not synchronized, so you need to set your upper/lowercase preference there as well.)


Re: Auto-uppercase keywords, nothing else
p-collab #44814 10/23/12 08:49 AM
Joined: Apr 2011
Posts: 49
Member
Offline
Member
Joined: Apr 2011
Posts: 49
and you need to edit all your templates to match your style!

Re: Auto-uppercase keywords, nothing else
p-collab #65719 05/23/24 02:36 PM
Joined: May 2024
Posts: 1
M
Member
Offline
Member
M
Joined: May 2024
Posts: 1
Hey @p-collab. Thanks for your post. I'm using PL/SQL Developer 15 and the first step now is:
  • Go to Configure > Preferences > User Interface > Code Assistant...

The rest of the steps still work.

Last edited by MrMotivation; 05/23/24 02:39 PM.

Moderated by  support 

Link Copied to Clipboard
Powered by UBB.threads™ PHP Forum Software 7.7.4
(Release build 20200307)
Responsive Width:

PHP: 7.1.33 Page Time: 0.029s Queries: 14 (0.008s) Memory: 2.5034 MB (Peak: 3.0396 MB) Data Comp: Off Server Time: 2024-07-17 13:56:03 UTC
Valid HTML 5 and Valid CSS